[BUGI] PPPoE and Eircom home-starter

Peter Edwards pmedwards at eircom.net
Wed Mar 17 12:56:25 GMT 2004


David Malone wrote:

>>I got one of these a few weeks back: I didn't do a thing with PPPoE: 
>>everything "just works" with A -current box and the netopia plugged into 
>>the same ethernet swtich.
>>    
>>
>
>OK - I tried to speak PPPoE directly, rather than letting the modem
>do it. I found the PPPoE RFC and I now think I understand the
>problem: the modem "relays" the PPPoE rather than passing it on
>directly and ng_pppoe has a problem with relayed PPPoE 'cos of this
>misdefinied constant. I've mailed freebsd-net to see if anyone
>objects to my fixing it.
>  
>

Curiosity got the better of me: I just sent you a private mail to the 
same effect on the misdefined constant.

>  
>
>>The netopia box is labeled "3341-EIR" on the bottom, and works like a 
>>charm, barring some DNS issues with AAAA records. It seems to at least 
>>ignore CNAME responses to recursed AAAA requests, but I didn't look into 
>>it much further, so I'm running the DNS server on my desktop.
>>    
>>
>
>That's interesting - do you get a NATed IP address or a real one
>with this setup? If it is a NATed one, have you tried speaking IPv6
>in IPv4 (either a configured tunnel or 6to4) through the modem?
>  
>
The modem gets a real IP externally, and provides a NATed network 
internally: you can use the on-board webserver to do reasonable decent 
NAT config as well. The device seems quite capable: I've been able to 
SSH to my local net from the outside world, and use a windows VPN client 
to talk IPSEC to a remote network through it, so it's reasonably savvy 
to tunneling issues.

I must confess my knowledge of  IPv6 is less than stellar (I've been 
working in telecoms too long: I've only just forgotten X.25). If you 
want me to try anything, gimmie a shout, but you'll probably get it 
working yourself first...

>	David.
>  
>




More information about the BUGI mailing list